Product Registration...how?

I know this has been asked elsewhere but I cannot find the answer.

I have signed up, have my code to enter,  can get on SE website but cannot figure where or how to enter the code. Anybody out there successfully entered the code, how do you do it and what goodies, if any, do you get. 

 

Discussion Info


Last updated July 4, 2018 Views 5 Applies to:

I too what like to know were to type in the code for the extra Tomb to go threw??

Is that what it gives you, an extra tomb? I'll sign up with the code if it's worth it.

E-A-G-L-E-S EAGLES!

Can you please provide a link/more details?

Read the sheet. You go to member.square-enix.com/na/, login, then click on the "Register Game" button. Type in your code and the game is registered. You usually don't get anything from these codes but SE points on your account.

It is VERY confusing.  Every day since this game launched, a pop up on the title screen would tell me to sign-up and link your XBL gamertag to your Square Enix profile.  So i finally did last night and had so much trouble.

.

So, I typed in my email address associated with my XBL tag on the menu screen of the game.  Then i opened my email and clicked on the link from Square.  Then on the website it tells me "i don't have a Square Enix account, please fill out this info..".  I did.  Then it tells me something along the lines of "there's no XBL account by that name...".  I then went back on the xbox and re-typed my address to request another link.  Tried it again.  Same result.  Four times and finally was able to link it.

.

Next i went to register my game with them, and this is where i think i found the root of the problem.  I'm on the "Register Your Game" page on the Square website.  It says that the code is found either on the back of the game manual or the Square Enix Membership leaflet found in your game case.  So i use the little leaflet, as there's no code on that joke of a tri-fold manual that they give you.  Then it asks to type in the "6-letter+3-digit, 6-letter+3-digit" code, or the "8-letter+4-digit" code.

.

I look at the leaflet and go what the heck?! The code is a four-set of four characters code.  So i logged out to tried again.  Then it came to my attention as i looked at the code on my paper compared to the code they wanted me to type in... then looked at the URL... I was on Square Enix Europe!  So i logged back out, went to Square North America, tried to log in, and it says "username doesn't exist".  Cursing under my breath to myself, i created a new Square profile this time on the NorthAmerica site.  And what baffled me, when i typed in my same username i had created on the Square European, it says that the username was available!  Meaning that the username i was currently using for their database, albeit their European site, seemed to be non-existant.  So after i created a new profile it said "congratulations on the creation of your new account.  A verification will be sent to the email u provided within 24 hours."  So i couldn't even log in til i received that email.

.

So this morning i got the email, verified it, and am good to go.  I registered the game with now problem, too.  But for some odd reason you can't link your Square profile to your XBL tag.  If you try it always goes back to Square EU and causes problems again.  So i said forget it, who cares.  At least the game is registered.  But another weird thing is, when i look at my registered games page, it lists my Tomb Raider game as a PS3 title!  Whatever!  I'm over it!

.

hope that helps, and sorry for the long post!

I have this problem too and I think its because their system it stupid flaky at the moment or multiple accounts mumbo jumbo. I remember having to make a NA Square Enix account in 2010. (<- That's exactly all it was called) Now according to Tomb Raider after starting up the game I need to sign up again. I do so, get my GT linked and find out the account is Members. These are already two accounts just putting that out there.

Anyway I wanted to register my game onto the site. I can't do it because the code I have doesn't want to type past the first letter I put it in. I then take a look at the region on the URL too and its stuck on EU instead of being NA. I didn't flipping make an EU account and specifically selected The United States when asked. Even when I login with my NA Square Enix account the moment I select Tomb Raider it logs me into the EU page.