Problems playing purchased SD videos

I've purchased a few full length movies from xbox video. Some of them are in HD and others are only in standard definition, but they are only available in SD. I've downloaded all of them and can watch them with no problem when connected to the Internet but I'm only able to play my HD ones when I am offline. The SD ones are in my list but when I click on them to play it comes up with the message: license for item is missing or corrupted. status code: 803c0008  I've tried deleting the videos. Clearing my system cache and re-downloading with still no success. I'm also experiencing a problem with my movie "the black hole" I have to delete it in order to watch it over live and now it only loads the audio track and keeps a black screen. This problem occurs with Netflix sometimes but is fixed after returning to the home screen, but I've restarted my xbox and the problem still pursists. It just seems like an awful lot of problems, but I hope someone can offer me some solid advice on remedying this situation. Thank you for your advice, and I'll try to post any additional information on the problem as it comes to me.

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Hi xKamiCosby,
 

Let's try refreshing your purchase history with the X button in the Account Management section of the My Videos ares in the Xbox Video app and see if that is able to help with the error you are seeing?Let's also try redownloading the profile and see if that is able to help. Let us know what happens. Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.