Problems Downloading Games in Arcade / On Demand / Demos for over A MONTH NOW!

This is starting to get on my nerves!

CONSISTENTLY for well over a month now....i find that my xbox is NOT downloading ANYTHING.....be it demos, arcade games, or games on demand...

Often times the games marketplace section of the dashboard will not even LOAD upon me pressing 'a'....so then i have to wait for it to fail, then press 'a' again, only to get in, but not be able to download anything. Images for covers of games don't load up, advertisments across the dashboard don't load up.

It's severely ruining my Xbox experience, for about a month now. WHAT IS GOING ON?? I can't possibly be the only one having this problem!?!!!

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Sounds like an Internet connection problem.  First try resetting your modem and router/switch.  Just turn off the power on each for a few minuets the reboot.  Hope this helps!!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi there NOVAtr1be! A hard reset like BongKaos here has suggested is a great first step! In addition can I have you please go to http://speedtest.net on a computer on the same network as your console, take the test there, and post the result image back here. Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

does your account region match your actual location?

that can cause some issues

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Some NAT problems are subtle and don't appear in the Test Xbox Live Connection test. Most likely there's a port blocked or misdirected away from your Xbox, in your router, modem, or at your ISP. Since the Xbox 360 uses different ports than PCs & Macs ordinarily use, you can't see the effect of a port blockage except on the Xbox, for the NAT problem is really the blockage or misdirection of ports.

 
A sequential power cycle is the first step in clearing a port problem, and the order and timing of the steps is important to success:


1) turn off the Xbox then
2) unplug power from the router (Some folks have a combination modem-router AKA 'gateway' or only use a modem with no router. If either, skip steps 3 & 6).
3) unplug power from the modem.
4) Wait at least 30 secs then replug the modem/gateway power.
5) Wait 'til the light on the front of the modem/gateway which says ONLINE, READY, CABLE or DSL is on solid (not flashing), then plug in the router. If you have a gateway instead of a modem and router or a modem with no router, then when that light says it's ready, skip to step 7.
6) Wait until the WiFi light on the router is on; you may not use WiFi, but it's still a good indicator your router is finished booting up.
7) Turn on the Xbox.  For more background on Ports, see http://whatismyipaddress.com/port

 
If the problem persists, please send us the info we need from http://forums.xbox.com/xbox_forums/xbox_support/f/9/t/155724.aspx so we may work on this further.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.