Problem with game update after install

Installed AC4 from disc. Had a few problems loading the game originally, once I disconnected from Internet it downloaded within 20 minutes. Now, my problem is the update. The game will work and play when I am disconnected from network. But when I connect it says AC4 needs and update (Getting Ready... Is displayed) then says "There was a problem with the update." It suggests that I check network connection (which is fine) CoD plays and connects to XBL with no problems. I know it isn't a problem with my end of the network. Could it be that servers are just bogged? I guess that isn't in the troubleshooting logic tree...
 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

I'm having a very similar issue with Lego Marvel Superheroes, and a scan of this forum shows others reporting similar issues with updates.  I played the game yesterday without any issues, so I suspect a system or server problem.  My network is working fine and games that don't prompt for an update are working for me, so I'm just going to wait another day and try again.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Call support. As soon as they answer, the update starts...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.