Problem with co-op

I purchased BF3 on release and installed it to my hard drive.  I have played mp, co-op and sp since with only about 4 times my xbox midgame would say unable to read disk and dashboard me.  I have been trying to play the co-op recently and on the last mission after you exit the subway and enter the bank my xbox says unable to read disk, everytime.  I have tried everything I can think of including deleting and reinstalling, clearing cache and even getting as new disk. Any ideas??

 

Discussion Info


Last updated July 3, 2018 Views 0 Applies to:

Turns out it was a problem with one of the updates.  I deleted and redownloaded them and now it works.  

Sounds like your disc drive bro.

No support yet, I hate calling them.  Only thing is my last box started not reading disks, but it was any game disk.  I am going to try not having it installed to my hard drive and see if that works.

Tried calling support? An odd problem indeed. If you even got a new disc, it sounds like it could be something wrong with he disc drive.