Post patch - some achievements are glitched.

I'll start by saying the game is great. Loved playing it and finally finished my first play through. Being my first play through I tried to find all the secrets, and do all the map stones etc.

When I finished though I have very low completed % on halfway, seasoned, world at feet, and no stone achievements. Has anyone found a way to trigger these? I maybe missed a couple of secrets, but I definitely got all the map stones, and certainly more than half etc.

I'd copied my save game, as I'd read that you should due to the game having some game breaking bugs... hence the ability to copy saves in the first place I'm guessing. I wonder if that new ability has caused new achievement bugs?

 

Discussion Info


Last updated July 4, 2018 Views 15 Applies to:

And, after playing through the game another time, I finally was able to unlock the map stone achievements.  It missed counting one during the the previous game, which was quite annoying.

And I'll take that Porsche.  Sounds good to me.

Sadly, it worked for me, too. (I used it in the secret chamber far up in the mountain region.)

Well, ... #!°= it, this is bad - ... in a way: I always hoped for a super secret chamber in which you can kill mario, luigi and link, and win a Porsche 911T with an airbrush of Kuro and the line: "Let's rowl !!!" on its hood. =P

Now I am on 100% achievements for Ori ... and I don't care about achievements at all. Kinda ironic. :S

I was able to get the secrets achievements to finally pop by following the instructions at true achievements.

Basically, follow these steps for those two achievements:

1) create soul link inside of a secret area

2) exit and backup the save

3) load backup save and go somewhere else and make a save

(I'm not positive if these steps are required or not, but what the heck)

4) Load the original save inside of the secret area and rekindle the soul link

5) exit to main screen and reload the original save

6) rekindle the soul link - exit, reload, repeat.

This finally worked for me.  I'm going to do some experimenting for the mapstone achievements now.   Very frustrating to not have these work as intended.

Nope, I'm afraid not :(. I had some tweets back from the developer, but they didn't help unfortunately. I've not got round to paying it through again, and not sure if want to go through it as carefully again, only to have the same issue.

I've had the same problem with the same four achievements.   Did you find a way to get these achievements to trigger?