Placeholders in "My Games" and "Recent" on the Xbox 360 in Germany.

Affected are the two apps "Youtube" and "Twitch".
And the games "Assassin's Creed IV", "Saint's Row IV"and "World Of Tanks".
The game covers are no longer displayed for several weeks.

 

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

This may mean some data on those games are corrupted, to fix this, go to the Dashboard>Settings>System>Storage and Highlight the Device that currently holds the game(s), Press Y and Select ''Clear System Cache'' or ''Clear Cache'' Be sure to do this a few times to make sure the console finds the corrupted content, After this I recommend launching the games and download any updates that may be deleted and look out for any DLC that could of been uninstalled.

If the Answer above did not work, Try deleting everything on your console associating the game (including the game) and then Reinstall/Re-download all the content and you should be fine.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This has nothing to do with my data stored locally on my Xbox 360. The data for the Games cover to download depending on the region from another server. I've tried it myself, the games that contain in the region "Germany" placeholders are for example displayed correctly in the United States, in Austria are still other games affected, also in Great Britain, etc.

You can check it yourself!

Launch Youtube or Twitch or any of the games described above , log out your profile, change your region to Germany: System->Console Settings->Language and Locale->Germany

Go to "Recent or "My Games"

"translated with google translater"

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sorry, you still have any game or app start before the dashboard can be loaded after you have changed the locale.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Alright, I`m not that good at solving problems that involve the server...but I reckon the only way to fix it is by changing the locale back, idk but maybe that app is not available in the locale you set it to making it so it cannot be displayed? Or maybe the server cannot recognize that app over those different servers (location based servers)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.