Pinball FX2 and tables won't unlock

"Purchased" Pinball FX 2 and a couple tables as part of a free promotion a few months back and I've never been able to get them to work. They download and open on my console, but act like they're still demo versions. I've tried clearing my caches and deleting the files and redownloading them multiple times. Still, whenever I try to choose a table it only gives me the options to "Unlock Table" (then wants me to buy it again) or start demo. Any suggestions?

 

Question Info


Last updated July 4, 2018 Views 11 Applies to:

Hey there Photo! Can you clarify that you purchased the base game as well, or was that a demo? Also, can you confirm you have tried deleting the content, clearing the cache, and then downloading it again in that order.

One other thing you can try is using different storage devices, like other hard drives or USB devices to see if the content will work there. Let us know of any differences there and we'll see if we can determine the issue from there. Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.