Overdog application connection problems

Hello all,

Using the preview program and the new NXOE, but have had this problem since the release of the application.
(How ever, beta version worked fine)

I decided i could live without it (and prob can) but i wanted to check it out.

You guys have any similar problems?

When accessing the OverDog application, i get to the main Logo, and further into the application, were i can see Settings, Home, Matchmaking.
And thats about it, then i only get the "loading circle"... and thats on there like forever.  I can't go anywhere or do anything.
Ive contacted OverDog about the problem and ofc they say its a Microsoft Update, and they can't see any problems in there end.

To drill down what i have done so far:

  • Hard Reset
  • Removed the Overdog application and re-installing it (Re-install after Hard Reset to clear Cache)
  • I have no NAT problems
  • Internet Speed is 1gb. And connection is Wired (Connection State is also 1 gb)
  • Everything else works, but the Overdog application.
  • Eliminated my Switches and router / IDS / IDP and used a "direct internet connection" from the Xbox One.

If anyone can think of anything or "know" that this is currently an error. Let me know.

Cheers

Acidgen

 

Question Info


Last updated July 4, 2018 Views 10 Applies to:
Answer

This has now Been resolved.

OverDog has release a new version fixing the problems.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.