Opening ports for Titanfall

I tried opening all the necessary ports for Titanfall, but I still can't get past "Retrieving Matchmaking List" and the Data Center still can't find anything, and checkmyports.net says the ports are still closed! What am I doing wrong?

 

Discussion Info


Last updated July 4, 2018 Views 4 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Are you saving the settings after you change them on your routers admin page?

Yes. I just double-checked it to make sure.

are you double port forwarding? meaning, using to devices like a gateway/router and a  standalone router? what are your NAT settings under the XB network settings?

I'm using an Arris TG852G/CT router and a Netgear WN3000RP range extender. Also, when I use checkmyports.net, the message I get is "Port 80 on 10.0.0.100 is closed! - Connection timed out," even though it barely took any time to check.

And my NAT used to be set to Strict, but when I started changing the settings to open the ports, it went to Open.

Uh...Hello? I still have the problem. Any solutions?

OK.

Before you start opening up a bunch of ports does your router have a UPnP option.

This should be enabled first before you opt to open any ports.

Having UPnP enabled and ports open can cause conflicts.

Enable UPnP remove any port forwarding and try connecting.

How do I do that? I'm checking my router's settings, but I don't see anything about UPnP.

I found UPnP under Advanced > Device Discovery, but it was already enabled.

Even with UPnP enabled, I too was getting not too good of a connection with the same gateway you have. What you want is a Cone Nat. I also lowered my firewall settings

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.