Odd MP error..?

Just recently, I've been playing gold and having a nice time until about ten minutes ago. I join a game and it won't exactly let me join. It starts after everyone readies up but then simply tells me it's "Waiting for other players..." while it's communicating. I know it's not my connection since every single things works fine. Are their servers having a bad hiccup today? Keep in mind, I didn't change anything for it to happen. Been playing for an hour, ended one match, started another, it just happened.

 

Discussion Info


Last updated July 3, 2018 Views 2 Applies to:

Update. Hm, seems to have sorted itself by restarting the game. Guess some host had a terrible connection?

it's a day of odd glitches. I was in a match today, and all the combat releated buttons on my controller stopped working. I could move, I could run with the A button, I could pull up the XBox Guide, or the menu with the Start Button. But none of the other buttons worked, I could not use any offense of any kind at all. Tried hiding and turning my controller off/on, grabbed a different controller.. nothing. I had to leave the match which I hate doing. Next match started, worked fine from there.

The OP's glitch is something I run into from time to time

usually it's because someone quits (or gets disconnected) before the mission starts but after it starts loading

Hm, that's weird. At least just simply restarting the game fixes it, so it's not too serious.

it happens to me when i try to enter a public or private always happens without fail please bioware fix this problem immediately to be frank i am getting quite sick of it and it discourages me from even think of playing the game!