No-show weapon upgrades

Why is it that only some of the weapon upgrades that I painstakingly collect (instead of spending my hard earned cash) end up showing up at the upgrade bench? Especially on the s'urkesh mission? It also happened in other places. Does anyone have a way around this bug? I've already tried deleting and re-installing the update, but it hasn't worked so far. When I go to pick them up, my omni tool lights up, but I don't get the notice on the bottom right saying that it's been added to my inventory....pleeeease help, I'm trying to save up for some armor and spectre weapons and having to buy things I've already collected sucks balls...thanks everybody...also, if anyone has an unused Cerberus code from ME2 and an unused multiplayer code for ME3 they'd be willing to part with I'd be glad to throw you some MS points or something.
 

Discussion Info


Last updated July 3, 2018 Views 4 Applies to:

Maybe you could be more clear on which game you are playing. You mention upgrade bench which is 2 or 3 then you mention saving for spectre weapons which is ME1. Cerberus code is 1000 micro points in market place. I think the ME3 code is 800. I seriously doubt anyone has any free give aways for you.