No audio through TV when using XBOX One? DVI to HDMI?

Hi,

I'm having an issue with my audio when trying to watch TV via Xbox One. I have no issues with the audio when playing games, watching netflix, skype, etc. but when I switch over to TV, I have no audio coming through my TV. The only thing I can think of is that I'm using a DVI to HDMI cable from my cable box to my HDMI in port since I don't have a cable box with an HDMI port on it. Would that cause the issue? If not, what can I do? I've tried changing the audio settings and messing around with the cables. I've also reset the Xbox One Watch TV and set it up so it matched my TV and cable box exactly. I also have an issue where the video is a bit too large and is cut off when through the xbox, but that's not nearly as much of an issue as long as I can have audio.

 

Question Info


Last updated July 4, 2018 Views 1,067 Applies to:

DVI has no audio channel. You would need to buy a specialty cable with HDMI to DVI and RCA.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Topbox: Motorola DCT6200/DC6208

Zip: 32303

Provider: Comcast/Xfinity Cable

I have a similar issue. I have a cable box that has a DVI out as well (with no HDMI out on the cable box..). So I'm using a DVI to HDMI cable to my HDMI in port on the Xbox One. I'm not getting audio or video when I try to watch TV. Sometimes the video from the TV flickers on then goes to black.. I've made sure my cable box is set to 720p output, and cycled the power on the Xbox One and cable box. Still just getting the black screen…  Any ides on how to fix this issue? Thanks for the help!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

DVI doesn't have any audio. It is the nature of the technology. The only way around is with an adapter or cable that injects the audio into the cable via rca or stereo 1/8" plug.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks Benny, is that also why there's no video? Unlike the original poster, I don't have any video (just a flicker then black screen), as well as no audio.. The Xbox One recognizes the DVI to HDMI signal and has all my guide info listed. Also, would you happen to have a link to the kind of cable/adaptor you're referring to? Thanks for the help!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just because your One Guide is showing doesn't mean the XBOX is receiving a signal. It just means your XBOX has loaded the Guide info from the internet. Check your Cable Box settings...try 1080i and 720p. If that fails try 480i (which would suck but at least give you an answer).

Don't know if I'm allowed to post links, but products similar to this:

www.amazon.com/.../ref=sr_1_2

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah, i wasn't sure if the guide info had anything to do with it. Yeah, I changed the settings on the cable box to output 720p and 1080i, still no change, black screen. I'll try 480.. I'll check out the link though. Thanks again!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No problem, the only other thing I can think of at that point is a HDCP handshake issue. Some older devices don't "talk" well via HDMI due to wonky HDCP (Copy protection).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah, I was thinking that too. I went ahead and ordered the converter. I think that may resolve the issue. I'll post back here when I get the converter. Thanks again for the help.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same set up I'm using and the same results ...Which I knew the DVI carried no audio ...I might hit town tomorrow and get me a YPrPb to HDMI cable .... fairly cheap on ebay ..so that means about triple at  radio shack ...lol

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.