Need some help with building a house in Hearthfire DLC!!

So I am having some trouble with being allowed to purchse the deed to build a house with the Hearthfire DLC.  So far I have tried in Dawnstar.  I've talked to the Jarl, but she hasn't asked me to purchase land yet, and a courier has not approached me either.  I completed the Waking Nightmare quest long ago, and have killed 3 giants for the Jarl, but still nothing.  Does anyone know what I am missing?  Any help would be great!! Thanks!!


Discussion Info

Last updated July 4, 2018 Views 1 Applies to:

When in doubt, Wiki it!


Look under Step 1.  You'll get the requirements before you can purchase your plot of land.

Thanks, but I've done the prerequisites already.  In Dawnstar for example, I've completed Waking Nightmare and killed not just 1, but 3 giants, and in Falkreath I', about to kill my second Bandit Leader, but still neither one has sent a courier for me or offered to sell me land.  Do I have to kill ALL the giants and Bandit Leaders?  Do I have to "activate" the DLC somehow, or does it just integrate automatically like I assumed?  This is frustrating me.....

I'm having the same problem in Dawnstar and Morthal. I'm assuming I just have to uninstall HT load a save where I haven't built a house, wait a week in game, save, reinstall HT, reset the console and then load up that save.

worked for Lost to the Ages for DG.

might try that tomorrow.

I did not follow the link above (it wanted to take me from this site and the comp I'm on now is a bit tricky), so not sure if this is addressed on the wiki.


Have you two tried finding each Jarl's own personal Steward? I believe he/she will have the deed if I remember rightly. Most of the Stewards for the Jarls can be found in or around their respective bosses longhouse. Took me a while to find the Steward in Morthal, must have been out having a smoke break or something. Hope this helps, if not perhaps deletion and reloading the DLC?

Best of luck!

I had the same problem when it first came out.  Some quests interfer with the property quests activation.  I went thru my misc quests did 2 or 3 then kept going back to jarls and it activated after a couple times.  Look at your fetch quests ie... bring this thing to that guy, those seem to be te sticky widgets from what I remember reading and doing.

Thanks alot, I'm going to try those things when i get a chance.  I did find the steward for Falkreath, but she was no help.  the odd thing I noticed is when i started trying to get the deeds I went to Dawnstar first.  After I collected my reward for killing the giant, it did not go away from my miscellaneous quests.  Now it just says for me to collect the bounty from the Jarl 3 times, since I killed 3 giants, but I'v collected all 3 $100 bounties.  Also, it says i need to help the people of Dawnstar, and has a "2/3" next to it.  Anyone know what that means?

It means you've done 2 out of 3 required tasks, according to the game at least. I do not remember the exact quests I did to get the deed, but I will have a look see tonight. In Dawnstar I completing "Waking Nightmare" and killing a giant were two of them... if you get frustrated enough the wiki will detail for you, and tell you any work-arounds (if any exist) for any known glitch impeding your progress.



If you care to peek.....


But, did the Jarl from the area you're trying to build the house in, give you the quest?


It has to be from his area, not the same kind of quest.  In other words, you have to get the reward from that Jarl.


You need to benefit his area - in order for him to let you buy the land.

I just did the uninstall and stuff and I have all three deeds now, just looking for some fine stewards so I don't have to gallivant all over the countryside.

In Dawnstar if you sell Iron Ore to Beitild, Quicksilver Ore to Leigelf and find the book for Rustleif then you should have no problem with becoming Thane of the Pale.  

So I have an update for my issue.  I traveled to Morthal, and soon as I got there a courier came up and told me the jarl in Falkreath wanted me to buy land, even though I just left Falkreath.  I now own land there, however I am having the same issue in Morthal as in Dawnstar.  I get requests from the jarl, or find a bounty at an inn, but cant get asked to buy land.  UGH!!