Need help QUICK [GLITCH]

Hi!

I was doing quest so i could get in to the alcane university but when i was in chaydinal and was going to do their mage guild quest i went in to the well and i got the Ring Of  Burden. But before the questlogg updated i dropped the ring due to fear of drowning. Now when i go back into the well the corpse is still there but the ring is gone! The green marker points to the wall to the left when u enter the well, i cant pick it up, i have tried alot. I dont have any other save then the auto-save so i cant reload.  I have tried to talk to the NPC that gave me the key and i have stonel the black Soul gems but i cant get the quest to progress.

PLEASE HELP ME!!!!

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

Unfortunately you won't be able to finish this quest unless you can find the ring and pick it up to register the quest update.

I would suggest just holding off on the Mages Guild for now since you won't be able to finish your recommendations. You can always create a new game to complete the Mages Guild if you want to get all the achievements. So, all hope is not lost. It just won't be on the same save.