Movie Rent: Texas Chainsaw (can't download error)

Client Used:

Xbox Video on Xbox 360

Movie:

"Texas Chainsaw"

(SD) (Rent) (Download)


The problem: 

I got an "Can't Download Texas Chainsaw" error on my Xbox 360.

I still paid for the download and I cannot watch or re-download the movie.
The "Rent" option disappeared (for some reason).

What I've tried so far:

I tried refreshing the purchase history and I have tried to "reinstall" Xbox Video by deleting all files associated with it and restarted the Xbox 360 and the Xbox Video App.

Enclosing.

Patiently awaiting your reply, regards from Kepala Monyet.

 

Question Info


Last updated July 4, 2018 Views 4 Applies to:

I solved the problem myself by the way.

Xbox 360:

- Settings

- System

- Storage

- Hard Drive

- Videos

Then deleted all failed-to-download files and then re-downloaded it with the Xbox Video App (on Xbox 360).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.