Mothership Zeta DLC glitch. Stuck & need help

I'm going through MZ & I'm almost at the end, on the "This Galaxy Ain't Big Enough.." quest. Sally is supposed to open the first two locked doors by climbing through a vent.

I activated the teleporter that brings Sally through to the room, she went through the vent & opened the first door. Now I'm in the second room (the one with circular glass floor) & she just stands on the glass floor in the middle of the room & won't budge. She's supposed to crawl in the vent, open the door & a hologram of an alien is supposed to appear on the glass floor (or so I've read).

I've tried reloading multiple times, I've tried pushing her towards the door, I even pushed her all the way back to the teleporter where we both went back to the Engineering Core. Nothing. She always runs into the room & goes back to the same spot.

Is this a game breaking glitch? Is there anything else I can try?

Thanks in advance

 

Discussion Info


Last updated July 3, 2018 Views 1 Applies to: