Marriage - just not working

Ok, at this point I really have had enough of Bethesda and their glitchy games. Looking online, getting married in Skyrim seems to have a multitude of problems, and now it's just cost me about a day's worth of playing.

It starts with me talking to Marathal, getting the marriage option, but then nothing happening when he askes me if I understand how marriage works. I pick one of the answers, and it just leaves the dialogue. Being a semi-intelligent sort, I figured out to just talk to my follower anyway (in this case Jenassa), and get her to agree, we set up the ceremony, etc.  However, after waiting for a day and walking back into the temple, I walk up to the altar where Jenassa and Marathal are waiting, and when I get there, nothing happens. We just all stand there, I can't move except to look around, no one talks. I tried reloading the autosave from entering the temple, and that got him to raise his arms and move his lips, but no words, nothing. I try waiting, nothing. Of course, waitning overrides my autosaves, so I the only way out was to use my last manual save, which I don't do all that often and cost me about a day's worth of playing.

It's a shame, because I'd have to say 2 of my top 3 game series were Elder Scrolls and Fallout, but now I've just had my fill of Bethesda and their rushed-to-market games loaded with glitches. I don't know why they constantly seem to have to rush their games through production, and why they can't just meet their deadlines so they can release a reasonably glitch-free game, but at this point I truly believe Skyrim will be the last Bethesda game I ever buy.

 

Discussion Info


Last updated July 4, 2018 Views 2 Applies to:

Did you reload a previous save? that usually works or try clearing the game cache itself I think the buttons you press are LB, RB and x and hold them till the bethesda logo shows up. If that does not work. then try clearing the regular system cache if not then i really don't know what to do.

Your game is obviously glitched for some reason. But, how can you blame Bethesda for a glitchy game when the marriage option works just fine for so many of us?  I also see people complaining about freezes, long screen loading times, dead NPCs needed for a quest, etc.  I did 3 playthroughs, got 1000/1000 gamerscore, and had none of those problems.  It's a mystery to me why some have problems and some don't. If the game coding were at fault, wouldn't we ALL have the same problems?  

The in game cashe reset, is that done in game or at the main menu?

Marriage worked fine for me. Also, these games are far from rushed.

HYPER- The game cache should be cleared upon start up.  Hold the LB, RB and X right after you choose the Play Game, release the buttons when you get to the start screen.

Just for the record, by definition a glitch is something that can't be explained or expected, so it can't always be reproduced exactly every time. So the answer to your question is NO, you wouldn't necessarily ALL have the same problem if the game was glitched. Sometime it glitches, sometimes it doesn't.