Main Questline Glitch (The Fallen) - Can't talk to Odahviing

I've seen this glitch referenced on the PC side of things, but I haven't heard if this is happening to anybody else on a console.

In the quest "The Fallen", I've arranged a trap for the dragon Odahviing at Dragonsreach.  He responds to my shout, and Dragonrend brings him down onto the palace's main porch.  He is quickly trapped, but nothing else happens.  He just sits there glaring at me.  I can fight him, reducing him to zero health which causes him to rear back (clipping through the dragon trap) before he re-enters the trap animation.  At no point in this does it let me speak to him to advance the story.

Does anyone else know what causes this bug, and what (if anything) I can do to move forward?  PC players can force a state in the game using a console command, but that's not exactly something we can do on the XBox.

 

Discussion Info


Last updated July 4, 2018 Views 182 Applies to:

Guess it's too late to warn about spoilers, because this one definitely should have one.

.

Oh well.

.

I don't know, however. I suspect your best bet would be to reload another save : ( Sorry not to have any advice.

I'm having the same stupid problem. I've even started a few saves back and it did the same thing.

I'm so annoyed getting this far and this has to happen.

Have you tried letting him out of the trap? I used the shout to call him, fought him til he had no health, backed up and let him chase me into the trap. From there you have to release him from the trap and the quest should continue...I've not encountered any glitches like this, so I always kinda feel people aren't doing it right, but its not always the case. Hope you figure it out, it was a fun quest.

I am having the same problem have done the quest multiple times and still can't speak to the dragon , I have tried to release the dragon but that don't work, cuz I can't talk to him and yes I have done the civil war quest and completed it

I had the same problem. I looked on the internet for remedies...The best one I got was to load a previous save. So I loaded the one when you entered the castle. First try it worked for me. But the site I looked on said to keep trying till it works.

Maybe do that silly little cache clearing dealy....might help too. ( I didn't do that )