Magic 2013: Impossible to play local multiplayer

Hi! I have a problem with the game Magic 2013 (MTG). When i am in the menu, and click on the multiplayer icon, its says "Additional content is needed to play multiplayer games. Do you wish to download the free update now?" If i say yes, it brings me to a menu to choose something to dowload, but i have dowloaded EVERYTHING and still doesn't work. I even bought the expension just in case it was that.

Can someone help me out?

 

Question Info


Last updated July 4, 2018 Views 7 Applies to:

Hi,

Can you try to clear your system cache and then try to go into the game again and see if the same issue persists?

Clear System Cache:

From the Xbox 360 Dashboard > Settings > System > Storage > Highlight your storage device > Press Y > Clear System Cache > Press Yes. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Thanks for your reply :) sadly this doesnt work, i still have the message :(

Thanks for your help :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Bulle! Can you try deleting this game along with any DLC (not saves!), clearing the console cache, and then downloading everything again? If that doesn't help, can you try on a different storage device, either Hard Drive or USB storage? Let us know if that helps

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Where is my game saved?  I would follow the above suggestions if I was confident I wouldn't loose my campaign and unlock progress.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Go to the System setting in settings. Then go to games and apps, search for Magic 2013, select it, delete the game ONLY. Not the save files.

Then, re-download it from the marketplace.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I only have two items listed under Magic 2013.  The arcade game and downloaded Items.  Unlike all my other games there is no save game file.  I do know one of these two files contains the save game (or its stored online) as I copied them to a USB drive and was able to continue my progress on a different Xbox.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I would suggest that it't the usb causing the problem. Try to copy the save file back to your Xbox.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I was having the same problem, then I deleted the Magic 2013 Multiplayer file. When I loaded the game back up again it worked just fine

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having this same problem.  I have tried deleting the game, associated files, and dlc (including multiplayer) and clearing the cache.  Still no luck.  Does anyone have any other suggestions?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Findlayfiend! If you haven't already, please go ahead and make a new thread detailing your issue and any steps you've taken so far to fix it. That is how these forums work best as it lets us tailor our support to you specifically. ^_^

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.