Lost Histories (Thieves Guild Quest)

This might be a glitch in the game but I am having trouble finding the butler Shum gro-Yarug in the Skingrad Castle. I need to find him in order to get a job to get to Theranis in the dungeon. He has a book that the Thieves Guild wants. I have tried to sneak into the dungeon with no luck. I have also tried to find him in town. If you talk to a Skingrad Guard they tell you that Shum gro-Yarug spend most of his time at the castle but he goes to the West Weald Inn at ten and the Colovian Trader at noon. I have waited at both spots for him numerous times and the correct times and he never shows up. I cannot advance in the Thieves Guild until I pass this quest. Any help on how to find the butler or maybe another way of completing the quest without him? Where is the back way into the dungeon? Also, if you get arrested and pick the lock to complete this quest how do you get your equipment back?

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

there should be a chest that holds all of your stuff, pick that and you have everything* back.

 

Now, if you have anything that is considered stolen.. they may not be in the chest.. can't remember how those items work if you sneak out.

 

As for sneaking/breaking in... heres the wiki, it should explain it better.. www.uesp.net/.../Oblivion:Lost_Histories

Shum Gro Yarog has a tendency to fall off the bridge that leads from the castle to the city.

So he's very likely to be dead.