Losing Peggle multiplayer connection.

I have been having a problem while playing Peggle peg parties where I lose connection to the other players.  I get an error message saying that my opponents have left the game and I am returned to the multiplayer menu.  When I select a new game I get the same match I was in, with the same people.  They have the same scores as when I lost connection, and its on the same shot, but my score is reset to zero and I get a random character. 

I am not being disconnected from xbox live, so I don't think its a problem with my internet connection.

Not sure if any other games are having multiplayer problems.

Is anybody else having similar problems?

Any solutions would be greatly appreciated.

 

 

Question Info


Last updated July 4, 2018 Views 4 Applies to:

By the way, I also tried deleting the game and clearing my cache and this didn't solve the problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Tim! I understand you are having some issue playing multiplayer games. Does this happen in any other games? Does this only happen when you play with certain people?

First thing, can you check on your router to see what your NAT setting is? If it isn't already, please set it to "Open". You can find more info on this here: forums.xbox.com/.../34069.aspx

Also, can you please go to http://speedtest.net on a computer on the same network as your console, take the test there, and post the result image back here. Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Turns out my router wasn't properly connecting to the internet.  All seems fine now.   Thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.