Legendary Edition Crashing on load

Hello guys, recently I bought the Legendary Edition, the games works perfectly, but when it comes to the extra content I just have problems,apparently the Downguard DLC works, but when I install the Dragonborn or the Hearthfire the game crashes on load, in Hearthfire I can't go to the open world area, in Dragonborn the console freezes when I load a save file or start a new game. What is happening? Can someone help me? Already tried to clear cache, delete and reinstall everything but it doesn't work, the game keeps freezing with both DLC.

 

Discussion Info


Last updated July 4, 2018 Views 8 Applies to:

I've not experienced this before, but I would offer a suggestion to maybe get the discussion rolling for you at least. First, does the Legendary Edition come with all the patches I wonder? If I recall, there are at least four of them that are major. If it didn't, and you downloaded them when the game prompted you, then maybe delete those patches and reinstall them, then try your three Expansion sets again. Not sure if you meant "patches" when you said you deleted everything?

.

You have the discs it sounds like? Maybe just play Skyrim from the optical drive without installing it (or any expansion pack until you reach level ten) if you have not. Aside from Hearhtfire, Expansion missions will not start until you reach at least level ten I believe. Then save your character to the cloud or a thumb drive to be safe, then install your Expansions.

.

If you patches are squared away, then might be a physical issue with your 360's hard drive? I do not own the Legendary edition, but I do have Skyrim installed on my 360 and all DLC were downloaded from the marketplace. My game freezes occasionally, but not like you are describing.

.

If it persists despite all your efforts and you think your HD is fine, maybe you can still exchange the Legendary Edition for the vanilla Skyrim? Hopefully with some coin back for the DLC? Hope you get this solved soon, this is a killer game....

Thanks a lot for the reply, and yes, I deleted even the patch, it could be my HD, I had some issues with GTA V as well, game reseting, but I'm not sure about this.

The Legendary Edition comes with just one "update", and you need to install it in order to access the menu for the instalation of the extra content, after the instalation, there is no other patch to download.

It could be my Xbox too, he is pretty old ya know, fat one and played a lot since the past years, I was at the school back then, so I played almost everyday for at least 6 hours. I'm planning to buy a new one, but I need some money, so I can't buy right now, it will take some time. I will try to resolve this problem a bit more, if there's no result, and going to go back to Vanilla and purchase the extra content online, looks like there are less problems this way. And again, thanks for the advise.

Sounding more and more like a hardware issue NP. Is there a friend who's let you try it on there console?

I have a slim now, well used, it runs Skyrim with the normal issues, occasional freezing and a crash or two. Mine has had very little problem with GTA V (or IV), all Halos, and such. I'll admit to being somewhat surprised by that! My original 360 (non slim) bit the curb about 2 yrs ago, coincidentally when I started playing Skyrim. It had MANY hours on it between myself and my kids. I think it was the processor and/or the GPU myself. It's up in the attic now, probably has mice living in it.

I'd make sure it isn't the optical drive before anything else, even if installed on your HD. Those are easy to replace. Inexpensive drives are available on Ebay, Amazon, etc, just make sure you know correct P/N if that's your play. There is plenty of help on google and YouTube for diagnosing and repairing it if you need it. I wish you luck sir!

Hello,

I cannot get past splash screen. The icon flashes then everything freezes. Up to date on patch.