Latest Titanfall title update fails to download

My Xbox One was updated successfully to the April 2015 release on Monday evening and I was able to play Titanfall just fine. When I tried to play it last night (Tuesday) Titanfall had still be running from Monday night. There was some error number on the screen which I was not able to write down but seemed to refer to the game having been disconnected from Xbox Live. No big deal, I thought, I'll just quit the game and restart. On restart, I got the screen indicating there was a title update. However, the update fails with the following message "There was a problem with the update" with no error number. I retried the update multiple times and it would never work.

I then decided to uninstall the game and tried to re-install in the hope it would solve the problem. Titanfall would not even re-install - the status would initially say "Queued" and then "Installing", but would never progress to 1% or beyond. I finally decided to yank the network cable and got the game re-installed. I plugged the network cable in and rebooted my XB1. I then tried to fire up Titanfall and got the title update prompt. Unfortunately, the update still fails every time. I then tried a full power down of the XB1 by pressing and holding the logo on the front of the console. On restart, I still experience title update failure. 

A friend of mine that I was trying to play with had no problem with the Titanfall update on XB1, but currently, I am completely unable to play Titanfall - Very annoying!!

Any help is appreciated!

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

Well, it looks like my XB1 fixed itself. I went to try it again last night and the game launched as normal so I can only assume the console automatically performed the title update overnight.