LAG!!!!!!!!!!!!

Whatever game I play whenever I try to play it I always lag persistantly; constantly red barring. My connection was amazing about a couple months ago and slowly declined into what is now a lag fest from hell. I've contacted my internet provider, upgraded to an amazing router, tried wired and wireless connections, connecting straight to the modem, and just about every support option out there. When I test my connection it's full bars across the board no problems whatsoever until I try to play then I realize who am I kidding? I'm rubberbanding constantly. There is no hope left. So I've decided to post my problem here in an attempt that there maybe something I overlooked or to have someone tell me that my xbox is just a piece of crap and I might need a new one? I just bought it not even a year ago. I'm just so frustrated please help.

 

Question Info


Last updated July 4, 2018 Views 6 Applies to:

I take it this is COD or Halo related? In which case try setting the search options to local only.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Oh wow that's amazing thank you so much :D I will play for a couple days and hit you up again if it persists

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.