knothole island

I've played fable II before and was able to get to knothole island no problem by visiting the dude at the river in bowerstone, but for some reason he won't take me there! . . . .and i cant buy anything from murgo either! . . . . . . . anyone got any ideas?.

Skye.

 

Discussion Info


Last updated July 3, 2018 Views 0 Applies to:

try completeing one of the main quests, then come back

in fact, invite me to help out :D

actually i just tried it myself, you should be able to go to knothold right off the bat. make sure you xbox is all updated i guess

still no joy ive. . tried completing all the quests to see if that would do anything but no such luck . . i mite just start it again and c what happens . . . thanks for your help much appreciated.

Skye.

I had a similar glitch when I transfered licenses. I had to removes all fable II items from the system memory and redownload them. I hope this helps.

Is the knothole island DLC worth getting? Thinking about replaying fable 2 with the DLC's.

Yes. I love it.

it was well worth it for me! except for the dog... that thing found something to dig up what seemed like every 5 feet, and usually repeats items a lot