Is it just me?

Is it just like my browser or my crappy laptop or does this site/forums run reaaaally slow?

 

For some reason like when I click to view a forums or really try doing anything of here it takes ages to load o.O

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

No, these new forums are a pile of [Mod Removed]

Not you it is this forum which is fairly new.

Previously known as Win7Xbox 360

Oooh, I see well that makes sense I guess, these forums are new? Sorry if thats a dumb question haha Im new to xbox.

I still don't understand why they changed it. If its not broke, don't fix it.

Since you guys obviously agree that something is wrong and it's not cool you should go post about it in the feedback section. They wanna hear from their customers, let em have it.

I've actually come up with a way to make it less frustrating. I'll have several tabs open. One of them will be the forums. Then I'll click on a thread I want to read and while it's loading, I'll check my email, see what's happening on Facebook, update my Q on Gamefly. Usually by the time I'm done, it's almost finished loading.

^^I actually had another tab open on the Gearbox forums the same way.  After three or four clicks I was reading posts on their site while still waiting for Xbox forums to load a single page.

Pressing F5 when using IE helps with the slow loading.

Previously known as Win7Xbox 360

I like the look of the new forums, but [Mod Removed] they're slow.

Posting in the feedback section is useless, they don't give a damn.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.