Initializing downloadable content package...

I'm trying to play freedom cry and I get stuck on the "initializing downloadable content package", does this screen take awhile to load? Ive tried it twice and sat around for 5 min each time
 

Discussion Info


Last updated July 3, 2018 Views 34 Applies to:

I found it took a long time to download but the in game screen doesn't show it. Had to find it in the xbox dashboard somewhere to see the installation progress.

Couple of times after it had downloaded the game crashed at that initialising downloadable content package message. Restarted the game and it loaded ok next time. Not worked out what stops it initialising in the first place.

Same here.  Freedom Cry is basically unplayable now, since every time I try, I get this, and then kicked back to the dashboard.  And its a shame too because I really was enjoying it......

I figured out that after it kicks me to the dashboard I load it up again and it starts, hopefully that'll work for you too

Thanks for the tips.

PS Jaylaggy was right

I read about an easier way to get it to work and so far it's 100%. Before you load up AC4, disconnect from the internet. Next, start the game and load freedom cry. Once your in game pause it( not sure if you ACTUALLY have to pause, but it's how I do it. Finally, reconnect to the internet and go back to your game.