I'm stuck to a Dragon Skeleton!!! LMAO!!!

I just killed my third dragon outside of Winterrun...and was glitched.  Now, everywhere I go in the city, I have the entire dragon skeleton attached to my foot, and I can't get away from it!  I've tried jumping, using the dragon shout to fast move away from it, magic, and I even tried to cut off my foot!  All attempts to  no avial.  It's really funny, and doesn't bother the game, so I just run around the city with the dragon stuck to my foot.  It's really funny when I enter a building and the skeleton almost fills the entire room.  All the NPC's act like nothing is there, too.   When I leave the city (fast travel, or walk away) it's gone, but when I return (again by fast traveling, or walking away), bam! Dragon skeleton stuck to my foot!

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

Pics or it didnt happen....

What about fast traveling?? have you tried that yet? That sucks, but is super funny too lol

Yeah, tried to fast travel, but doesn't work.  The skeleton doesn't affect any quests or where I go, and it's changed from annoying to just plain silly.  Only shows up in Whiterun, so that's good.

He said it isn't there when he leaves the town.  So it is a problem with his character in town.  Fast traveling might help for some odd reason but loading out of town already removes it.  Going back in puts it back on.

I wants some pics!

Do I dare ask how it looks if you ride a horse?  :D

That's funny.

Y'know, always gotta watch out for the **** you step in.