I Can't Go On Anymore Due To DLC Content

I was at 5% of the game until the penguin said he didn't want me picking his locks (electronically) then blam I get booted out of the game.

Don't get me wrong Arkham City has potential to become GOTY, I just wished that they left  the Catwoman DLC alone.

 

 

 

Discussion Info


Last updated July 3, 2018 Views 2 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I hope they make newer copies without giltches

Beside's harley being pregnant , Joker returning (I hope) I don't know this is my second rental despite what happend when I played it the first time.

In the future the community as a whole would probably benefit from you using spoiler warnings before posts like this.

Guys I have some sad news I have took the 2nd copy back to blockbluster damn this sucks

I did too Gazzy, which is why I think it is a glitch due to the DLC being there when he started the game, but then it was removed.

Because frankly, any game designer that would have any kind of non-free DLC be REQUIRED to finish a game would be burned at the stake.

I finished the game without the DLC, no issues.

You aren't going to like at least one of my two solutions:

1) delete and then from your download history re-download the DLC. It is possible that the game is hanging because you HAD the DLC, and now that you don't, the game is confused.

2) this one slightly builds on the first - It is possible that your game is "set" to have the DLC. Because you don't have it (having deleted it), it doesn't mesh with some bit of code that for those without the DLC (like myself) lets them play seamlessly.  So if #1 doesn't work, you're going to have to delete the entire game file on your console (or memory stick, where ever it saves to) and start all over again.

Those are what I think would fix the issue, but no promises.  

No I actually bought the DLC the first time around & the game said the content was broken.

Tried the second copy input the code, worked ok then screwed up again.

Deleted the dlc played till I got to the penguin then the game booted me out

I can't believe it's because you haven't downloaded the Catwoman DLC.  Some people don't log in to Live or PSN.

Are you sure you didn't have something downloading in the background?  Batman is one of those games that boots you to the main menu when something finished downloading in the background.

Not having the DLC doesn't stop you from being able to finish the campaign.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.