House in Solitude - Possible Spoilers*

Has anyone bought the house in Solitude? I am wondering because from what I have read on the internet, it is horribly bugged so I am afraid to purchase it.  I don't think their patch was geared towards repairing it so I'm just wondering if anyone has had any issues with this house.

 

Thanks,

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

I haven't personally bought it, but I know someone who has, and a little while after he bought it, it wouldn't let him enter. The house kept saying "Key Required" even though he had the key.


So, I've held off on purchasing it for the very same reasons as you. I've heard way too many bugs and glitches surrounding the house. I'd advise you to just wait it out until the next patch, because I don't think it's been fixed yet.

Ya that's what I figured.....thank you!

I bought the house in solitude twice now the first time it would'nt let me use wepon racks so I loaded a checkpoint before I bought it then got it again then most wepon racks worked the two one ethier end wont tho and some wepons go on racks side waays, it's a glitchy house yes but I like kinda have to lost 25k on it and yes it doe's say key's requierd but just press open and it will open it did that to me but the buy depends on if your picky or not hope this helped sorry bout the spelling issue's

ok, that's good to know - thank you

My primary house is in Solitude.  There are 2 or 3 different entrances and I noticed at first only the staircase entrance would let me in.  I kept trying each time and eventually I could use the other door.  The cool think is that the clothes on my mannequin keep respawning after I take them off and return later.  It's a very nice house, but the only other house I have at the moment is in Whiterun and that one is just fine too... it's conveniently next to a blacksmith, but it lacks an enchantment workbench.

I bought and the only "problem " it had was with the left mannequin but TBH  worked more in favor than in v.s. If i unequipped a complete set of armor it appear like naked but if you press A to equip the items you unequipped were still stored so served as a dupe glitch to equip companions IMO. So is not completely bugged at all. I got it before the second patch.

I bought it a few days ago, have not had a problem with it.  You get a Thane and I also transferred my wife to it.  Nice looking place, multiple entrances, can enchant weapons, make potions; no problems.

-

Not conveniently situated like the Whiterun home but not too far.  

-

I've never used a weapons rack in any of the homes, I just dump EVERYTHING in a chest and leave it.  I like everything in one place ready to access which also will help should I forget where I put things.

-

I would say a must buy.

I didn't have any problems with the Proudspire Manor, but it's disappointing as it is the most expensive house but has NO DISPLAY CASES.  Not even one.  However the house in Windhelm (which does have a horrible bug, thanks to "The Butcher") costs less, has more one more mannequin, has around 6 display cases and like 10 or so plaques to mount weapons on.  I just hate that the crap from The Butcher litters the house.  Still I think it is the better of the two.

Count yourself lucky SquareFantasy, due to a bug I am unable to purchase this home.  It shows in my misc. quests and I go to the guy but it is never ready.  I have talked to everybody in town and helped countless of people.  The people talk about the Butcher and somehow something in the graveyard is to happen but mine won't trigger it.  Plus, and i don't know if these are connected, I can't kill a dragon as it flies backwards and is always out of reach.  This just happened yesterday so have gave up on that.  I now have over 11 quests unfinishable due to bugs.

My only problem with Proudspire Manor is the clutter.... The place looks like it needs a maid. My wife doesn't do much.