Help Please. new copy of skyrim, but wont play??!!!

hope sombody can help me with this.I bought Skyrim today as it was half price. took the  game home and tried to play but i am getting nowhere fast.  i get  disc is unreadable errors even though the game is brand new without a mark on the disc. .ive tried playing it offline no joy... ive tried playing it without the hard driveplugged in, same error. it wont install, still getting a disc unreadable error.it is the same region as my machine so that shouldnt be a problem. all my other games work fine. ive tried deleting the cache, turning off autoplay, then resetting the xbox but still no joy.  any ideas help etc would be much appreciated, soooooo frustrating......

 

Discussion Info


Last updated July 4, 2018 Views 4 Applies to:

take the game back if its giving  you this many problems and get a new one.

I would take it back and get another copy.  

-

I had that problem with Rainbow Six Vegas 2 only to take it back and then have the same errors again.  Turned out my machine was starting to break down and the new disc was merely a coincident but at least I as able to narrow the problem down.  And surprisingly I could still play other games it as just finicky with this new disc.

-

Take it back and if no problems with new disc than you are good as gold.  Did the copy you buy for half price; was it a "used" disc?  That could be the problem as well.  Wouldn't be the first used disc I or others had that had problems.  I have seen some places will "buff" the surface of scratches however some machines have problems with this while others won't.  

it wasn't a pre-owned disc, brand new out of the packaging. ill take it back tomorrow. thanks for the advice all

There was someone a long time back in the Mass Effect 2 forum that had this same problem with that game. Turned out to be a defective disk, he exchanged it and all was well. Hopefully that's all it is and you'll be fixed up in no time. Good luck!