Halo 4 Multiplayer connection

For the past two days I have been unable to play any multiplayer games on Halo 4. Whenever I tried, it would load in incoming players, allow me to select a map, and then right as the last beep goes off to start the UNSC eagle loading screen I get bumped back to the lobby. When I joined my friends' party, they all continued onto the match while i was sent back. At the bottom of the screen it says that everyone left the party but when asked they said that I was the only one who left. I've already checked my connection multiple times, reset the wireless settings, as well as restarted the modem and router. The thought that I've wasted my money is not making this any easier so any help would be appreciated.

 Thoroughly frustrated,                                                          

Jex                                                                          

 

Question Info


Last updated July 4, 2018 Views 5 Applies to:

You should check that your 'NAT type' is not closed as that will affect your online experience. This could however, be due to server difficulties as other players on the Halo.Xbox.com forums have said that they too are not able to play normally at the moment. Try unplugging your router/modem for 30 seconds and restart your Xbox. If that still doesn't help, then I can only suggest that you wait until this issue is resolved.

-

For more information regarding NAT types, see this; support.xbox.com/.../nat-type-strict

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.