Guardian's of middle-earth, survivor mode issue.

Hi mate!

I'm new in the forum, and hoping this isn't the wrong section for this post.

This night I've bought the survivor mode for GOME, and at first time I've started the game, all was ok.
But since this morning, 12 o'cloc circa, the game tell me that the add'on is damaged and put me in gold mode till i'll redownload the survivor mode.
I've done it. But the Issue still.

Any one can help me? I''ve payed a bit, but I've payed.

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Delete the add on from your hard drive, clear your systems cache the reinstall it. See if that helps you out.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank a lot Dude! The add still work now!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Always happy to help a fellow gamer

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.