GTA V phone Internet not working?

I can't seem to open my in game internet  properly when I do so it would close immediately and my mini map would disappear and I won't be able to access anything on the phone including text, e-mail, camera etc until I reload my game, I loaded a game save file earlier in the game about 50% complete and the internet's fine but now in my main game save 86% completion it would not load I tried using all 3 of the phones even Jimmy's laptop all would't work except when I opened a URL from the E-mail like from Ammu-Nation and some ads there, I might be able to surf all the other sites except  (eyefind the homepage) but I think I need to type in the store's URL manually which sucks big time also if I click home it would just close again..  so anyone please help?? 

add info

I tried restarting the game/xbox, loading an activity/replaying a mission but nothing seems to work... I don't know when I can't use the web, I only realized when I was trying to get the "A Lot of Cheddar" achievement when I attempted to use the stock market, which in the end I loaded a older game save and kept investing all my money selling and buying back the shares until I "spent" 200 million now I'm trying to buy a plane and the buzzard but I'm stuck so can any kind soul post the in-game sites for the Military hardware and Flying Vehicles one until someone manage to help me fix this? Thanks! 


Discussion Info

Last updated July 3, 2018 Views 1 Applies to:

Same issue here. I just come out of a game in GTA Online into the free roam on-line mode. I pulled up my phone to deposit money. The main webpage open and then closed very quickly and the mini map was gone.

I left the on-line portion of the game and now my regular game save is behaving the same way as you have described. Game Save is 86.5% complete. If this in an ongoing issue or something that can not be more Rockstar for me.

After playing a bit more...the game is totally unplayable after I try to access the internet with my phone. As stated before the mini map is missing, I can't switch characters and other interactive things can not be interacted with (ex: no option to watch TV's).

mine's fixed already after the patch but you can try going to ammunation's website for the e-mails then type the links manually or look for an actual ATM to bank in?

The thing that still annoys me about the phone when using the web browser is having to constantly press B over and over just to back out of it.

[quote user="AlmasRetroChild"]

The thing that still annoys me about the phone when using the web browser is having to constantly press B over and over just to back out of it.


Press Y :D

Oh lol thanks.

I just got this glitch today. (On latest patch.)

Was going through level replays, for the "solid gold" achieve, finally checked the net and glitched.

They need to get some kind of information out on this. My game is at 100% with all but one single player achievement, the "Spend 250 mill" one.  

No way am I starting over R*.  

I'm kinda scared to load my online character, what if it transfers over. hate to try and find an ATM every time I need to stash cash.