GTA IV Connection Issues

I tried to connect to a game with my friends (around 5 of them) and it wouldn't let me. Typically we just change the host if this happens, but after we did that for all of us I still couldn't connect to anyone. Then we all reset our routers/modems and checked router settings (DMZ, etc) and checked our NAT types (all on Open). Still couldn't connect.

Then something strange happened; I could no longer receive any type of message from anyone (text/voice message, game invite, party invite, etc) unless I signed in and out, then all of the messages I received would appear. I tried to accept an invite from a friend, it took me to the GTA start up screen and then tries to load the multiplayer up, but it says 'Unable to join game session that you have been kicked from' even though I haven't even joined a game yet.

I'm in the middle of recovering my gamertag now to see if this fixes anything. This is the first time it's happened to me since I started playing GTA and if anyone can give some advice it would be appreciated. Cheers. :)

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Okay, cheers. Hopefully it's resolved soon.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am also having similar issues.  This post sounds familiar too.  Doesn't sound like the issue is a problem with our network configuration, this points to a Live problem.

forums.xbox.com/.../559832.aspx

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.