GOW3 Beta unlocks not working

Hi

On my main account I have played and unlocked all the items in the Gears of War 3 beta but on the actual game the unlocks are not working.

I have spend a considerable amount of time researching this on the internet and have tried; restarting the xbox, choosing storage device, clearing cache, etc and it is still not showing up.

I am very disappointed as I also purchased Bulletstorm so I could get access to all the unlocks and now am not able to access anything.

Please could you advise asap.

Many thanks

Z

 

Discussion Info


Last updated July 3, 2018 Views 0 Applies to:

Do you still have the beta file saved to your hard drive, and is it in the same spot as your gears of war 3 saves? If you do and it still doesn't work you may have to wait on the title update Rod was talking about in his podcast. I'm in the same boat with not having all my beta stuff unlock.

Call Xbox Support and choose the Xbox Live section. They'll help you out. I had the same problem