Glitch's in the Keep. Please Help.

I was doing The Traitor's Keep Quest. Follow Commander Milton. He stop, just before you jump down. But I did jump down. Now I can't go anywhere, all gates are locked. I also tried going back to Dashboard and start up the game again. But it just starts where I'm stuck. I also tried picking a new quest. But it says I can't start on new one tell I'm completed the one I'm on. Does any one have any ideas or do I have to start all over. I hope I don't have to start all over. If I do will it have anything I have done with this one??

Please help and Thank you for your time. :)

 

Discussion Info


Last updated July 3, 2018 Views 6 Applies to:

Lets see if you are stuck in the canyon. You will have to start over since there is no way back up. If you are on top with the commander you can try to push him sometimes pushing a character will get him or her to move again. Also sometimes just walking near the destination will sometimes teleport the character to you. this only works sometimes just like the pushing thing. So if none of these work you have to start over.

Hopefully lionhead will make a patch for all these glitches but like i wrote in another post they most likely wont because they are working on fable the journey.

Thank you for the info. I'll remember for next time.

But that really bytes. This game went from a 9.5 to a nice even 8.

So I got though the sec. time. I saw how it happened tho.

It was when he was talking about the guy we were hunting and some guys came into the room. So I killed them and ran.

So make sure you let him finish what he's saying.  Before jumping down.