glitches and freezing after installing new hard drive

Been playing Skyrim for a month or so now on a new 360 slim. Everything fine. Yesterday finally got a hard drive (had previously been saving on internal memory unit) and, after installing it, started playing. As soon as I booted up my most recent save wacky stuff start's happening. Random things are purple, and the game is very jumpy. After a few minutes, it freezes.

Today, I try again. Same story. I do some online research, try a bunch of things, no luck. Now game is freezing during the loading screen (sometimes before START appears, sometimes after). I can't even play for more than a couple minutes now without it freezing completely. Also, weirdly enough, my perfect-condition disc is refusing to install. Makes it 7% and then says disc is scratched. Was able to install another game. Turned off autosave as soon as game booted and that didn't work either. It's my weekend off work and I wanted to laze and play, please help!

Things I've tried:
Clearing cache several times,
Deleting old saves,
Removing hard drive,
deleting and re-installing most recent patch and cleaning the disc about a hundred times

Any other ideas? I'm running out of options and patience. Thanks!

dd

 

Discussion Info


Last updated July 4, 2018 Views 0 Applies to:

Sounds like your HD might be faulty. I could be wrong though... Make sure the drive is in properly, then try playing without installing and see if it has any issues, then try installing again.

Still no luck. Removed the problem-causing HD and still having the issue. Trying everything with no luck. Anyone?

Too many Freeze ups for me just couldnt take it anymore!!  

I had a terrible time with this game after way too many hours in. I finally had to delete it from my X-box and start all over. I did find 2 sets of saves though. One appears when the game is running and the other is in the settings, game storage of your console.

You might try? Completely remove game and all saves including cloud. Set up your console and let it do the latest online update from Microsoft. Last one was yesterday the 20th. Then give it one more try before getting tech support involved.