getting "The game couldn't start. Try downloading the game again" error

So this is going to be a rather long story, but here goes nothing.

I have a 4gb slim console.  Just recently bought in November because my old *** whitey couldn't play gta v without freezing (still pissed about that)  Anyway, I am using a sandisk 16gb usb flash drive as my main storage for my console, it's basically filled up (about .5 gigs left) so I went out and bought a 64gb flash drive on ebay
(here's the link: http://www.ebay.com/itm/Brand-New-64GB-Flash-Drive-USB-2-0-Black-Silver-SALE-/251414955545?pt=US_USB_Flash_Drives&hash=item3a897fc619)

to use as bigger storage.  I didn't know the max storage was 32gb, but i thought that would be plenty if I ever wanted to download or install a couple games. 

The issue I am currently having is with the error "The game couldn't start. Try downloading the game again".  I have a digital copy of sleeping dogs installed to the 64gb, and it plays fine (took under an hour to download).  However, I went to install Fight Night champion on the same flash drive, it took over 3 hours, and when I went to play it,, I got the above error.

I have tried deleting and redownloading multiple times, reinstalling dashboard updates, redownloading my profile and clearing caches but to no avail.  Also have partitioned the flashdrive different ways including the default auto configuration, and each time it says it meets minimum specs and should work fine.  It seems like I can only have one game downloaded at a time to this flashdrive.  I reformatted a couple times and tried with different games.  I downloaded dishonored, and it played fine.  Then I tried downloading dragon age 2 and got the same error (to clarify, dragon age 2 did download, but I got the error when I went to play it from the "my games" tab)  I've had this problem with disc games too, but that might be another issue.

Also note that when I went to install the second game, I turned my xbox off, and when I turned it back on hours later, the installed game was corrupted.  So I wiped the flashdrive and reconfigured, installed sleeping dogs (it played with no problems) then installed fight nigh champion, went to play and got hit with the error. 


I'm thinking it might be just the cheap flashdrive, but then again the console says it meets specs and should work so I don't know.  If someone had this issue and then fixed it by buying an official sandisk, I would go ahead and do so, but as it stands I have purchased a fully compatible flashdrive that simply does not work properly. 

Any help would be appreciated folks!!  Thanks.

 

Question Info


Last updated July 4, 2018 Views 46 Applies to: