Getting disc read error, but downloaded the game from marketplace?

I downloaded Borderlands 2 from the marketplace when it came out. It worked fine the whole time. But today I am getting the "Cannot read disc" error, even though there is no disc in the drive. Is there anyway to fix this? I have an Xbox that is not more than 4 months old with 250G HD.

 

Discussion Info


Last updated July 3, 2018 Views 6 Applies to:

if you have the Mechro character and the Pirates booty head equipped it can make the game crash. check on that, if it doesnt help then im not sure.

no i have commando. I add that I had a really hard time downloading that compatibility pack, it took several attempts. For some reason it wouldn't show up in my downloads at first.

I just started getting those too. It's not my disc. It worked fine up until the night I downloaded the compatability pack and tried to play on Xbox Live for the first time. Now I get the error every time I try to play. I've tried deleting all my DLC, my character saves, and cleared my cache. TBH I'm pretty p.o. about it.

damn thats sucks. a bunch of my friends online are gettin this problems also, both downloaded game and disc.

I get this problem with all my games. I can play them fine on the disc but if I install them I get the disc unreadable message. I looked around for a while and it sounds like its my harddrive going bad.

I just downloaded the game and every time I kill Incinerator Clayton it says disc can't be read. My character if the Mechromancer, but doesn't have that pirates booty head on. Is there anything you did to make it stop?