Gears of War 3 Multiple System Link Error

Hey

Tonight some friends and I decided to play GoW3 over system link in Horde mode.
We tried multiple setups to get it to work, at and BEST, we could all join the host's game, and play 1 round of horde, before we inevitably got disconnected with the error message "Lost connection to host".

We followed the instructions found here:
http://support.xbox.com/en-US/xbox-360/settings-and-initial-setup/connect-system-link-play

We updated all three consoles, all three versions of the game. We all own an Xbox 360s. We tried through a wired connection with a router, and through a wireless connection. We found the wired connection more reliable - However we still couldn't proceed without someone disconnecting. We had 5 players, spaced over 3 consoles. Some of us had an Xbox Gold account, some silver. We even tried direct connect Lan cable from one xbox to another, and that didn't work. We tried multiple different lan cables as well, just to be sure.

I've seen a lot of questions about this on the internet, but no real answers or suggested fixes. I've heard things about it being an issue with an update in other forums, but can't get any clarification.

Clearly this is a common issue, but is there any fix for it?

 

Question Info


Last updated July 4, 2018 Views 8 Applies to:

I had this issue and the most reliable solution I found as stupid as it sounds was to host a private game online. Obviously if you'd need gold for that which isn't ideal but you can use guest profiles for splitscreen so as long as you have one gold account per console you're good to go.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.