Game/system freezing during 'Leviathan' after installing 'Citadel'...

I got 'The Citadel' recently and started a fresh game (default story, no
imported files). Played up until you can go on shore leave and did 'Citadel'
dlc. After that I did a couple side missions and decided to do 'Leviathan' next.
I got up to the point where you meet Garneau (sp?), chase him through a few
rooms, and then you climb a ladder that leads to the mines. When you climb the
ladder a loading screen appears... and my game/360 freezes during it every
time.

I can't say for sure that it's 'The Citadel' causing this, though,
as I never replayed 'Leviathan' after getting 'Omega'. I only recently tried
playing through 'Leviathan' for the second time, but it did work fine the first
time around before Omega and Citadel were released.

For background,
I have all single/multi DLC's (including appearance/weapon packs, extended cut,
javik, etc.), and have both game discs installed on my harddrive. Have also
tried playing the DLC via both game discs and it freezes at the same spot no
matter the disc.

Anyone else have this problem or know a fix?

 

Discussion Info


Last updated July 3, 2018 Views 2 Applies to:

I never say this because there is usually no pint but if I were you I would clear my cache. If that doesnt help then I would delete the DLC and re-download it. One of these two things should fix it. If not then ya got me.