Games' Download/Installation Cannot Be Completed

I brought many xbox one games in digital copies and stored them in my library. I have been trying trying to download/ install some of them to my console these days but surprisingly found out that no matter which game I try, the download/installation just cannot be completed -- it just goes up to a random percentage and stops there, falls into a installing/queued loop with the percentage fixed without any progress.

I checked my internet connection and found no problem; I checked available space and found there is plenty of room. I tried to reset the console; I tried to cancel the download and restart it from 0; I tried all suggested solutions from the support guide but none of them work.

This is not a problem specifically occurs to a certain game, it is a problem for all digital games I tried to install. Therefore, I am unable to install any game now and it is really very frustrating.

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Im having the same problem. Elder Scrolls has been at 77% for about a day. Borderlands actually downloaded with that que loop but it took about a week.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.