Game stuck on ''Saving content.''

Hi everyone!

So I'm kind of new to this Xbox thing, and lately I've been playing Skyrim and I'm really enjoying it. However, for some reason today it kept on being stuck at '' Saving content '' whenever I want to save it. I'm at the point after I release the Miasma (does this ring any bells to anyone?) and whenever I try to save it, it's just stuck on ''Saving content.. please don't turn off your console''

I have tried clearing my cache and I know it's not smart to turn off your console while it says that, but it won't allow me to do anything else!
If anyone could help me, that would be amazing..

Thanks in advance,

Jay!  

 

Discussion Info


Last updated July 4, 2018 Views 4 Applies to:

Are you doing the quest called Waking Nightmare? If so, I'm guessing you're freezing coming out of the Dreamstride sequence. If so, it's a known bug fixed in the patch that is currently waiting to be certified by Microsoft. However, if this is place you're freezing, just don't save until you're back out in Skyrim & you'll be fine -- there's literally less than 5 mins of gameplay after that point, so it shouldn't be any trouble getting outside & safely saving w/o freezing. Also, if you have auto save turn on (which you shouldn't, btw), turn them off until you're back outside.

Additionally you could try playing another game, or at least download some content off the marketplace to see if it saves properly.  This is simply to test to see if the hard drive is working properly.

Thank you guys for your responses!

BlackHawkDrunk, I have followed your advice and the game works ~perfectly~ now. I still have auto save turned on. Why do you think I should have it turned off?

Bethesda games always work better w/ autosave turned off. Something to do with the frame rate drop when an autosave is triggered -- this can lead to corrupted save files. Also, autosaves tend to happen after a load screen & I'll tell you this; there's nothing more scary in gaming than a Bethesda load screen. Some people have been lucky & not affected by this, many have been unlucky -- myself included. Nevertheless, I'm glad I could help.

I have to agree with you BlackHawk on this one. My game runs soooo much better since I turned off "autosave" and the problems nearly stopped all together.