Game Room won't start.

I just tried to load up Game Room...and it simply won't let me access my games. Every time I start it it seems to loading normally as usual...until it gets done loading the games off of my hard drive, then it just goes back to the title screen asking me to press start (Instead of taking me to the main menu of the game). And if I press start it freezes the entire system. This is a problem I have never had before. I've already tried clearing my cache and that didn't solve my problem. So what's going on here?

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

I suggest deleting the game content from your HDD, then clearing the cache again, and lastly, re-installing it from your Download History (which can be found under 'Account Management' in your profile).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.