Fusion Genesis/Dashboard problems/help

I downloaded the new dashboard and Fusion Genesis recently and it played fine for a while but now I rarely can even get to the ESRB rating before getting booted back to the dashboard (assuming it starts up at all). I'd get pushed out of the game sometimes before but that was extremely rare and this is happening every single time. I tried deleting the memory cache, deleting the game and downloading it again multiple times and nothing's working! I put dashboard in the title because I noticed that the game order took a second to put Duke Nukem 3D and Manhattan Project in the "right" order, that's when I tried Duke Nukem 3D and noticed that, sure enough, it was having problems too, namely freezing so I'm pretty sure it's not just Fusion Genesis but the whole dashboard update as this is far from the first time they've screwed with my games. (Seriously for the love of god why must they constantly change it over and over again?!?) I tried testing my connection to download the update again but the option never came up.

Has this occurred with anyone else? I'm at my wits end, I need help or confirmation that something's being done.

 

Question Info


Last updated July 4, 2018 Views 4 Applies to: