Freezing and restart during titanfall gameplay

I purchased the titanfall bundle on Saturday and attempted to play the multiplayer game, it keeps feeezing and restarting in every game I play. I have called Xbox support twice and they tell me to reset it and unplug it from wall and all the leads from Xbox. I have also been told to uninstall game and reinstall the game, but still no luck. I'm getting over this system and console. I want answers to why a brand new console is acting up after I just paid $600 for it and can't even play the game that the bundle is named after.
 

Discussion Info


Last updated July 4, 2018 Views 16 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Got the exact same problem just freezes with a loud whiring sound and crashing to the dash, If It's not doing that It's losing connection and chucking you back to the lobby

This has now happened three times to me.  Lots of lag and then sound locks and repeats for a while and then shuts down to dash board.  I have lost my burn cards and some great games!   It's getting very old to the point i just  turn the one off and head back to 360!

Mine freezes AFTER FIVE MINUTES OF PLAYING EVERYTIME, IM TIRED OF THIS CRAP ITS LIKE THE RED RING OF DEATH ALL OVER AGAIN!!!!

Same thing is happening to me. Game freezes after about a min reaching the title screen.

I was having problems with Thief and Dead Rising and Titanfall - seems like a memory problem - so I sent it back for a new one - I'll let you know if it was fixed -

Also having a similar problem, was on the phone twice with support and tried numerous hard resets and re-installs but Titanfall still freezes up after the EA screen.

Same problem i have titanfall for xbox360 and i can get two games in and then it just freezes up!!!!

Just bought my Titanfall bundle today and now it's happening to me too. Freezes five mins in or so. Just spent £400. Great.

Same thing has happened to me a few times. Clearing the persistent storage in my blue ray/dvd settings seemed to help.

I would try a few things:

Hold down the power button on the front of your console for eight seconds (until it restarts).

This should fix it but if not...

Delete and reinstall

Try hardwiring your system using ethernet (as opposed to trying to play over wifi) and see if this helps.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.