For some reason Battlefield 4 took to long to start. (0x8027025a) Digital Copy

I get this error every time I click on Battlefield 4 to play it. Have owned for about a month with nothing but problems. However this is the first time I have encountered this problem. I have restarted the One in every form and fashion that anybody has put on the internet. I have not tried to uninstall mainly bc I have three attachtments for the Premium and it would take a long time to uninstall all three and reinstall, and it not work so I am looking for any other answer. Any help would be great thanks. Also this is a digitally owned game no disc

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Unfortunately you're right, that error code doesn't really tell you the issue besides it loaded slow and as you said you tried restarting to no avail. I think you may have to bite the bullet and go for a reinstall of the game.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.