Fable Anniversary problems

I had to post this cause it has to be known. 

Bought my first copy and tried to install it, it gets 22% of the way and says it can't read the disc and says to clean it.  Tried it about 10 times and took it back and exchanged for another copy.  Brought it home and the same thing happened.

Went ahead and just played it off the disc and these are the problems I'm having..

1.  Put in DLC codes, got my avatar Lion hat but not the DLC wardrobe

2.  Obvious game freezes everywhere

3.  Stuck doing the escort quest and it's not possible to heal the two being escorted (Thus not getting the achievement)  /  They die with full health randomly  /  Finally got to the troll and beat it, and while it's dying falling back into the earth, the mission failed screen pops up saying they've died.. but with full health or three quarter health.

I love this game but want to play more FOR THE LOVE OF GOD! ~Chris Farley  voice~

 

Discussion Info


Last updated July 3, 2018 Views 10 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Only thing I can try to offer help on is healing the escorts.  I assumed, incorrectly, that you could give them food from your inventory but that was not accurate.  The only way to heal them is with a spell.

Thanks for the reply, it's been so long I forgot all about that.  haha

But I did revert to an old save and everything is working fine until random freezes loading into a new area but I just restart the Xbox and everything is fine.  

I tried the clear cache 3 times, let opening screen sit 5 min before starting game. Also tried many other things suggested by XBox phone support. Nothing helps.

I have had the following problems.

1. A button often won't respond, especially in conversations and tutorials.

2. B button sometimes won't respond.

3. Game freezes and have to shut down console to restart.

4. Items on D pad won't access when needed in battle.

5. Can't access journal during battle to get food or potion when needed. Health goes down and I die while clicking repeatedly on a potion if it is showing on D pad.

6. Escort quest is majorly bugged. Traders die with full health. Then game puts me back to last checkpoint.

7. Save system dies not work as promised. It will only save from last checkpoint ir last auto save. We were promised we could save whenever we want.

These issues are what I've found after a few hours of trying to play. Thus game us so bugged it is impossible to play....A waste of money!

The save system does seem a little wonky, but mine will occasionally just let me save from where ever I am at.  I will agree that is kind of annoying.

It's a broken bag of crap and i'm fed up of being played for a muppet by game publishers releasing unfinished buggy crap.

I rented this over the weekend and yes it does indeed have many problems.  It froze on me at least 5 times in the few hours that I played the game. Also a bit frustrating in combat when it auto-locks onto friendlies instead of enemies.    I decided to return the rental.

I got this, was enjoying it and had no problems at all. Then I turn it on one day and it needs an update, download the update and since then every 20 mins or so it freezes. Haven't played it since.

Is anyone else having issues with the SmartGlass staying stuck on the title screen on a Win Phone 7 device? I have a HTC Trophy that I've forced the 7.8 upgrade onto and have bought the SmartGlass upgrade and all I get to look at is the title screen.

It is upsetting to see that alot of people are having issues with the game. The only issues I have had was a couple of times randomly freezing while walking around the guild gardens.

I've been playing for 10-11 hours now and haven't had any freezing/lag issues.  *Knocks on wood*

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.